Log in

FutureSight Forums

Index » Tech help » THEY'RE FORCING ME TO USE EDGE! (Atom feed)

Pages: 1

#1: 10 Aug 2015 01:13

offline Krett12

Member

I recently upgraded to Windows 10, and Chrome, Opera, Firefox, etc don't work anymore. The only one that does is IE which they're now calling "Microsoft Edge" for some old reason. Do you think this is on purpose?

I tried installing PowerBrowse but it didn't work. I'll try using the in-firedust browser next.

#2: 10 Aug 2015 01:30

offline Krett12

Member

Here's something worth noting: The image below says "You are running Windows XP and using Chrome!" for me.

#3: 10 Aug 2015 02:28

offline Jacob

Administrator
user avatar

I upgraded to Windows 10 and am still using Firefox... It did change the default browser, but I was able to change it back.
What are your computer specs? It's possible that your system simply doesn't support it anymore.


Jacob G.
Executive director and co-head developer

#4: 10 Aug 2015 04:12

offline Krett12

Member

Which specs? Hardware? When I bought this machine it came with Windows 8....it should work.

#5: 10 Aug 2015 04:14

offline Krett12

Member

Even things like Steam are starting in offline mode, and they're not even browsers (even though it has one)

#6: 10 Aug 2015 04:17

offline Krett12

Member

My dad says I should copy my data off and use System Restore to downgrade to Windows 8--should I listen to him?

#7: 10 Aug 2015 04:38

offline Jacob

Administrator
user avatar

This doesn't sound like a problem with Windows 10 so much as your setup. If you're running an old computer, it's possible that they simply can't run on your hardware. If a lot of stuff is running slowly, that might be the cause. Also, when you upgraded, did it warn you about any drivers/programs becoming incompatible? I haven't seen anyone else report similar problems, and everyone in my house (3 people including myself) uses Windows 10 with a different browser (I use Firefox and the other two use Chrome).

You could downgrade to Windows 8 and that would fix your problems, and you honestly probably wouldn't miss out on that much.


Jacob G.
Executive director and co-head developer

#8: 10 Aug 2015 05:28

offline Krett12

Member

No, it didn't. I know this computer is new because I opened it out of the box myself.

#9: 10 Aug 2015 07:40

offline Jacob

Administrator
user avatar

Krett12 wrote
No, it didn't. I know this computer is new because I opened it out of the box myself.

Do you have any weird software on it? That also could be messing with it.


Jacob G.
Executive director and co-head developer

#10: 11 Aug 2015 15:03

offline Krett12

Member

What do you mean by weird?

I think Microsoft is behind this. They are quite sleezy and may have purposefully made Edge the only working browser.

#11: 11 Aug 2015 15:04

offline Krett12

Member

Should I put the files in Alphabet drive?

#12: 12 Aug 2015 02:16

offline Jacob

Administrator
user avatar

Krett12 wrote
What do you mean by weird?

I think Microsoft is behind this. They are quite sleezy and may have purposefully made Edge the only working browser.

They do sometimes do questionable stuff, but given that nobody else seems to have this problem, I don't think it's intentional. By "weird", I mean stuff that's not widely known. Also, you should probably run a virus scan. That's probably not the problem, but it could be.

Krett12 wrote
Should I put the files in Alphabet drive?

What do you mean?


Jacob G.
Executive director and co-head developer

#13: 12 Aug 2015 13:34

offline Krett12

Member

k

#14: 17 Aug 2015 13:38

offline Krett12

Member

My dad upgraded to 10 so he could "share the pain"

Index » Tech help » THEY'RE FORCING ME TO USE EDGE! (Atom feed)

Pages: 1

Embed topic (Show)